Email Delivery Delays to Outlook / Office 365

Incident Report for Carerix

Resolved

The temporary delays affecting outbound emails to Microsoft and Outlook addresses have been resolved. Normal mail flow is fully restored, and our systems are currently delivering the remaining queued messages. No emails were lost during this event.
Posted Sep 04, 2026 - 15:05 CEST

Investigating

We are currently experiencing delays when sending emails to Microsoft Outlook and Office 365 addresses. Microsoft's receiving servers are temporarily returning a "Server busy" response and instructing our mail servers to try again later.
Posted Sep 04, 2026 - 14:01 CEST
This incident affected: Carerix applications platform.