The matchbox

Incident Report for Carerix

Resolved

The issue has been resolved. The MatchBox is available again
Posted Apr 23, 2026 - 18:30 CEST

Investigating

We are currently experiencing the unavailability of the matchbox. We are investigating the issue.
Posted Apr 23, 2026 - 16:41 CEST
This incident affected: Assisted Matching.