Some Carerix portals are temporarily unavailable due to emergency maintenance
Incident Report for Carerix
Resolved
This incident has been resolved.
Posted Apr 20, 2018 - 09:10 CEST
Identified
Portals will be available again shortly.
Posted Apr 19, 2018 - 16:59 CEST