Manual email synchronisation fails
Incident Report for Carerix
Resolved
Manual email synchronisation is working properly again.

Apologies for the inconvenience.
Posted Nov 17, 2017 - 10:09 CET
Investigating
We have several reports that the manual email synchronisation is not functioning properly. We are aware of the problem and are working on a solution.
The automatic email synchronisation IS working.
Posted Nov 17, 2017 - 09:49 CET