Servicedesk is temporary unavailable
Incident Report for Carerix
Resolved
This incident has been resolved.
Posted Sep 16, 2021 - 10:55 CEST
Investigating
Our service portal is temporary unavailable, support calls can still be sent in via email, phone or chat.
Posted Sep 02, 2021 - 17:08 CEST