We are currently unable to receive any calls. Due to maintainance to our telephone system,
Incident Report for Carerix
Resolved
This incident has been resolved.
Posted Jun 24, 2022 - 11:04 CEST
Investigating
You can reach us via mail: (helpdesk@carerix.com) or make a ticket via the Jira Portal.
Posted Jun 24, 2022 - 09:57 CEST