Possible incident with Carerix services
Incident Report for Carerix
Resolved
We have identified the problem and resolved it. Our apologies for your inconvenience.
Posted Feb 20, 2018 - 08:09 CET
Investigating
We have received reports that there may be an incident with the Carerix services.
As yet, it is unclear what components are affected.
Please watch this page: As soon as we know more, this page will be updated
Posted Feb 20, 2018 - 07:57 CET