Slow or unavailable applications
Incident Report for Carerix
Resolved
Issue resolved.
Our apologies for the inconvenience
Posted Feb 23, 2018 - 11:43 CET
Investigating
Some customers report application is slow or unavailable.
We are aware of the situation, and are working in resolving this a.s.a.p.
Posted Feb 23, 2018 - 11:33 CET